<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"r0YveJg3p6KS9r",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"wvue"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "wvue/web/news/crime",
    "authors": [
                  
                    {
                      "_id": "mariesimoneaux",
                      "name": "Marie Simoneaux",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2019/03/13/da-man-sentenced-years-strangling-ex-girlfriend-burning-her-body/",
    "contentId": "IW7GYJUZENG55LFRRJNVSR3KLM",
    "contentName": "DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body",
    "contentOwner": "wvue",
    "contentTags":  [
                  
                    {
                      "text": "gary harris",
                      "description": "gary harris",
                      "slug": "gary-harris"
                    },
                  
                    {
                      "text": "ray harris",
                      "description": "ray harris",
                      "slug": "ray-harris"
                    },
                  
                    {
                      "text": "nannette king",
                      "description": "nannette king",
                      "slug": "nannette-king"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2019-03-13T21:38:58.300Z",
    "description": "Gary Harris pleaded guilty obstruction of justice and manslaughter last month in the murder of Nannette King.",
    "hasVideo": "false",
    "metaDescription": "Gary Harris pleaded guilty obstruction of justice and manslaughter last month in the murder of Nannette King.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Crime",
                            "_id": "/news/crime",
                            "path": "/news/crime",
                          }
                        
                      ,
    "publishedDay": "13",
    "publishedMonth": "03",
    "publishedYear": "2019",
    "stationName": "wvue",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="QMIqc4W0gyDrYdshalYUNrjZ6ruVa0CmuXGU-ofhuqs"/> <title>DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body</title> <meta name="keywords" content="gary harris, ray harris, nannette king, gary harris bush, gary harris murder, nannette king murder, nannette king bogalusa"> <meta name="news_keywords" content="gary harris, ray harris, nannette king, gary harris bush, gary harris murder, nannette king murder, nannette king bogalusa"/> <meta name="date" content="2019-03-13T21:38:59.578Z"/> <meta itemprop="description" name="description" content="Gary Harris pleaded guilty obstruction of justice and manslaughter last month in the murder of Nannette King."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="http://www.fox8live.com/2019/03/13/da-man-sentenced-years-strangling-ex-girlfriend-burning-her-body/"> <meta name="twitter:title" content="DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body"/> <meta name="twitter:image" content="http://www.fox8live.com/resizer/Zy1AiVVOXf_MvRuPkfZrL2r6noc=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/26LMF2B6XJCPNGRF6ZOSRIHH5Y.jpg"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="Gary Harris pleaded guilty obstruction of justice and manslaughter last month in the murder of Nannette King."/> <meta name="twitter:site" content="@fox8nola"/> <meta name="twitter:creator" content="@fox8nola"> <meta property="og:url" content="http://www.fox8live.com/2019/03/13/da-man-sentenced-years-strangling-ex-girlfriend-burning-her-body/"/> <meta property="og:title" content="DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body"/> <meta itemprop="image" property="og:image" content="http://www.fox8live.com/resizer/Zy1AiVVOXf_MvRuPkfZrL2r6noc=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/26LMF2B6XJCPNGRF6ZOSRIHH5Y.jpg"/> <meta property="og:description" content="Gary Harris pleaded guilty obstruction of justice and manslaughter last month in the murder of Nannette King."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="http://www.fox8live.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="1745950605625242"/> <meta property="fb:pages" content="107322144609"/> <meta property="fb:admins" content="644426401"/> <meta property="article:publisher" content="https://www.facebook.com/FOX8NOLA/"> <meta property="article:tag" content="gary harris, ray harris, nannette king"> <link rel="amphtml" href="/2019/03/13/da-man-sentenced-years-strangling-ex-girlfriend-burning-her-body/?outputType=amp"> <meta name="author" content="Marie Simoneaux"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body",
        
        "image": {
          "@type": "ImageObject",
          "url": "http://www.fox8live.com/resizer/Zy1AiVVOXf_MvRuPkfZrL2r6noc=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/26LMF2B6XJCPNGRF6ZOSRIHH5Y.jpg",
          "height": 468.0,
          "width": 1200
        },
        
        "datePublished": "2019-03-13T21:38:58.300Z",
        "dateModified": "2019-03-13T21:38:59.578Z",
        "articleBody": "COVINGTON, La. (WVUE) - A North Shore man who admitted to strangling his ex-girlfriend and then burning her body in 2015 last month was ordered to serve 50 years in prison Tuesday (March 12), according to the St. Tammany Parish District Attorney’s office.Gary Harris, now 57, of Bush pleaded guilty to manslaughter and obstruction of justice by tampering with evidence on Feb. 14 in the murder of 42-year-old Nannette King, D.A. Warren Montgomery said in a news release Wednesday.King was reported missing on Sept. 20, 2015, the D.A. said, after never returned to the Bogalusa motel where she and her daughter were staying. Her body and car were found three weeks later, badly burned in a wooded area near Sun. Harris and King had an adult daughter and lived together for many years. Before her disappearance, King moved out of their home in Bush to Bogalusa with their daughter. Investigators called Harris and King’s relationship “volatile.”Investigators said Harris strangled King to death at their once-shared home after luring her there to collect her things. Harris’ brother, Ray Harris, later admitted he picked up Gary from somewhere near the location King’s body was found. He also confessed to hiding evidence. A spokeswoman for the D.A.&#039;s office said Harris was initially charged with second-degree murder, but pleaded guilty in February in exchange for the reduced manslaughter charge. District Judge Raymond Childress ordered Harris to serve 40 years for the manslaughter charge and an additional 10 for obstruction of justice, to be carried out consecutively.Ray Harris, now 67, was also sentenced Tuesday, when Childress ordered him to serve five years in prison for accessory after the fact. Copyright 2019 WVUE. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Marie Simoneaux"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "",
        "logo": {
          "@type": "ImageObject",
          "url": "http://www./pb/resources/images//logo_meta.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "Gary Harris pleaded guilty obstruction of justice and manslaughter last month in the murder of Nannette King."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "",
        "url": "http://www.fox8live.com",
        "logo": "http://www.fox8live.com/pb/resources/images/rm_icons/wvue-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/FOX8NOLA/" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/792648f9b5901ea0287e/rm/rm-framework792648f9b5901ea0287e.css?v=51" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/wvue-logo.svg?v=51)}</style> <link href="/pb/resources/dist/792648f9b5901ea0287e/rm/rm-framework792648f9b5901ea0287e.css?v=51" rel="stylesheet"/> <link href="/pb/resources/dist/792648f9b5901ea0287e/rm/rm-features792648f9b5901ea0287e.css?v=51" rel="stylesheet"/> <link href="/pb/resources/dist/792648f9b5901ea0287e/rm/rm-services792648f9b5901ea0287e.css?v=51" rel="stylesheet"/> <script src="/pb/gr/c/default/r0YveJg3p6KS9r/arcAdsJS/84612eb819.js?v=51"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="f2pQ2l2YSXIS9r"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.fox8live.com/bbb-accredited-business/" class="color-grey-dark">BBB Accredited Business</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0AC08OYSXIS9r"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0NEonbYSXIS9r"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.fox8live.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.fox8live.com/live/" class="">Watch Live</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news/investigate" class="">We Investigate</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/video-gallery" class="">Video</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.nolaweekend.com" class="">NOLA Weekend</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/contests" class="">Contests</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/programming" class="">TV</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/homepage" class="color-white">Home</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.fox8live.com/live/" class="color-white">Watch Live</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.fox8live.com/apps/" class="color-white">Fox 8 Apps</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.fox8live.com/programming/bounce-tv-nola" class="color-white">Bounce TV NOLA</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/community/user-content" class="color-white">Send It</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="http://www.fox8live.com/news/editorial" class="color-white">OurVue / YourVue</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news" class="color-white">News</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/news/national" class="color-white">National</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/morning/video" class="color-white">Morning Edition Video</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/coast-in-crisis" class="color-white">Coast in Crisis</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/john-snell" class="color-white">John Snell</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/news/investigate" class="color-white">We Investigate</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/news/investigate/lee-zurik" class="color-white">Lee Zurik Investigations</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/investigate/state-of-unrest" class="color-white">State of Unrest</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/news/investigate/cracking-the-code" class="color-white">Cracking the Code</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/news/investigate/medical-waste" class="color-white">Medical Waste</a> </li> </ul> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/news/investigate/crimetracker" class="color-white">Crimetracker</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/news/investigate/defenders" class="color-white">FOX 8 Defenders</a> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="http://www.fox8live.com/defendersform" class="color-white">Defenders complaint form</a> </li> </ul> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/video-gallery" class="color-white">Video</a> </h3> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/weather" class="color-white">Weather</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.fox8live.com/weather#radar" class="color-white">Your Weather Authority Radar</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/sports" class="color-white">Sports</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/sports/nfl/saints" class="color-white">Saints</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/sports/nba/pelicans" class="color-white">Pelicans</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/sports/ncaa/lsu" class="color-white">LSU</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/sports/ncaa/tulane" class="color-white">Tulane</a> </li> <li class="list-unstyled padded padded-sm padded-right li-7"> <a href="/sports/high-school/football" class="color-white">Football Friday</a> </li> <li class="list-unstyled padded padded-sm padded-right li-8"> <a href="/sports/bigfish" class="color-white">BIGFISH</a> </li> <li class="list-unstyled padded padded-sm padded-right li-9"> <a href="/sports/golf" class="color-white">Golf</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/community" class="color-white">Community</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="/gr8neighbors" class="color-white">GR8Neighbors</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="/community/heart-of-louisiana" class="color-white">Heart of Louisiana</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="http://www.fox8live.com/food/recipe" class="color-white">Chef John Folse's Cookbook</a> </li> <li class="list-unstyled padded padded-sm padded-right li-6"> <a href="/community/calendar" class="color-white">Community Calendar</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="http://www.nolaweekend.com" class="color-white">NOLA Weekend</a> </h3> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/politics" class="color-white">Politics</a> </h3> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/programming" class="color-white">TV</a> </h3> <ul class=""> <li class="list-unstyled padded padded-sm padded-right li-3"> <a href="http://www.fox8live.com/programming/schedule" class="color-white">TV Listings</a> </li> <li class="list-unstyled padded padded-sm padded-right li-4"> <a href="http://www.fox8live.com/programming/me-time" class="color-white">Me Time With Frangela</a> </li> <li class="list-unstyled padded padded-sm padded-right li-5"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </li> </ul> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/contests" class="color-white">Contests</a> </h3> </li> </ul> <ul class="float-left list-unstyled links uppercase min-width-25 padded padded-sm padded-top padded-left"> <li class="list-unstyled padded padded-sm padded-right li-1"> <h3> <a href="/about-us" class="color-white">About</a> </h3> </li> </ul> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0HTBN5YSXIS9r"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-wvue-breaking/" data-url="/pb/api/v2/render/feature" data-website="wvue" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fKmSyu1YSXIS9r"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/wvue-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="wvue"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fYIkcb1YSXIS9r"> <div id="ad657-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad657" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad657",slotName:"wvue/web/news/crime",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"IW7GYJUZENG55LFRRJNVSR3KLM"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="fyu1Wq1YSXIS9r"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="DA: Man sentenced to 50 years for strangling ex-girlfriend, burning her body" src="http://www.fox8live.com/resizer/hDmb4bGlS641OG2BkUo8DvA8X0o=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/26LMF2B6XJCPNGRF6ZOSRIHH5Y.jpg"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> Gary Harris, 53, arrested for the murder of Nanette Me'Shell King. (Source: STPSO) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="cdn4ps1YSXIS9r"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share flex-container-column text-align-right"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=DA%3A+Man+sentenced+to+50+years+for+strangling+ex-girlfriend%2C+burning+her+body&amp;url=http%3A%2F%2Fwww.fox8live.com%2F2019%2F03%2F13%2Fda-man-sentenced-years-strangling-ex-girlfriend-burning-her-body%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter icon-light"></i> </button> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.fox8live.com%2F2019%2F03%2F13%2Fda-man-sentenced-years-strangling-ex-girlfriend-burning-her-body%2F&amp;title=DA%3A+Man+sentenced+to+50+years+for+strangling+ex-girlfriend%2C+burning+her+body', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square icon-light"></i> </button> <a href="mailto:?subject=DA%3A%20Man%20sentenced%20to%2050%20years%20for%20strangling%20ex-girlfriend%2C%20burning%20her%20body&amp;body=Read%20more%20on%20DA%3A%20Man%20sentenced%20to%2050%20years%20for%20strangling%20ex-girlfriend%2C%20burning%20her%20body%20at%20http%3A%2F%2Fwww.fox8live.com%2F2019%2F03%2F13%2Fda-man-sentenced-years-strangling-ex-girlfriend-burning-her-body%2F"> <button class="button button-icon button-icon-hover-accent button-xl button-dark button-round spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <i class="far fa-envelope icon-light"></i> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="ftk6561YSXIS9r"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/mariesimoneaux/"> <span class="font-bold ">Marie Simoneaux</span></a> <span class="font-bold">|</span> <span class="timestamp"> March 13, 2019 at 4:38 PM CDT - Updated March 13 at 4:38 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0RgmFAYSXIS9r"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>COVINGTON, La. (WVUE) - A North Shore man who admitted to strangling his ex-girlfriend and then burning her body in 2015 last month was ordered to serve 50 years in prison Tuesday (March 12), according to the St. Tammany Parish District Attorney’s office.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Gary Harris, now 57, of Bush pleaded guilty to manslaughter and obstruction of justice by tampering with evidence on Feb. 14 in the murder of 42-year-old Nannette King, D.A. Warren Montgomery said in a news release Wednesday.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>King was reported missing on Sept. 20, 2015, the D.A. said, after never returned to the Bogalusa motel where she and her daughter were staying. Her body and car were found three weeks later, badly burned in a wooded area near Sun. </p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Harris and King had an adult daughter and lived together for many years. Before her disappearance, King moved out of their home in Bush to Bogalusa with their daughter. Investigators called Harris and King’s relationship “volatile.”</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1307-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1307" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1307",slotName:"wvue/web/news/crime/IW7GYJUZENG55LFRRJNVSR3KLM",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Investigators said Harris strangled King to death at their once-shared home after luring her there to collect her things. Harris’ brother, Ray Harris, later admitted he picked up Gary from somewhere near the location King’s body was found. He also confessed to hiding evidence. </p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>A spokeswoman for the D.A.'s office said Harris was initially charged with second-degree murder, but pleaded guilty in February in exchange for the reduced manslaughter charge. District Judge Raymond Childress ordered Harris to serve 40 years for the manslaughter charge and an additional 10 for obstruction of justice, to be carried out consecutively.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Ray Harris, now 67, was also sentenced Tuesday, when Childress ordered him to serve five years in prison for accessory after the fact. </p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2019 WVUE. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f0lr2vsYSXIS9r"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="http://www.fox8live.com/2019/03/13/da-man-sentenced-years-strangling-ex-girlfriend-burning-her-body/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="http://www.fox8live.com/2019/03/13/da-man-sentenced-years-strangling-ex-girlfriend-burning-her-body/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fNw7nD1YSXIS9r"> <div id="ad1591-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1591" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1591",slotName:"wvue/web/news/crime",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"IW7GYJUZENG55LFRRJNVSR3KLM"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f03xXkCYSXIS9r"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-cloudy" data-default-location-code="USLA0338" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="wvue" data-location-code="USLA0338" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USLA0338,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="http://www.fox8live.com/weather"> <img class="radar-image" src="http://webpubcontent.raycommedia.com/wvue/weather_images/local_radar_img.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="77" data-temp-c="25"> 77</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/67_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>New Orleans, LA</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="http://www.fox8live.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0vcuYOYSXIS9r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="frTbte1YSXIS9r"> <div class="flex-feature height-full"> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-144606" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/03/13/feds-charge-including-tv-stars-widespread-us-college-admissions-scam/"> <img class="width-full " alt="Coaches and parents in college scheme find jobs in danger" src="http://www.fox8live.com/resizer/UJok2LDNhejeKlMzdPKVQ5Y5EHo=/0x5:756x383/756x378/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/73H62K54TJET7LCHVXKXVAPASA.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/03/13/feds-charge-including-tv-stars-widespread-us-college-admissions-scam/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Coaches and parents in college scheme find jobs in danger</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Prosecutors said parents paid as much as $6.5 million to bribe coaches and administrators at sought-after colleges to guarantee their children's admission.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2019/03/13/million-path-bomb-cyclone-across-central-us/"> <img class="width-full " alt="‘Epic’ storm brings blizzard, rain, tornado threat to US heartland" src="http://www.fox8live.com/resizer/rKIK2iO3sUT6MwjOtuiTbgGB_Ts=/4x0:1540x768/1536x768/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/7AY3HTECWJCKRAZTSETSAJM7BA.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/03/13/million-path-bomb-cyclone-across-central-us/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; ‘Epic’ storm brings blizzard, rain, tornado threat to US heartland</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">It's called a "bomb cyclone," which is a rapid drop in pressure over 24 hours. Among the areas expected to get hit hard: the central-northern Plains, the upper Midwest and the Rockies.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f04Lyj2YSXIS9r"> <div id="ad1418-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1418" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1418",slotName:"wvue/web/news/crime",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"IW7GYJUZENG55LFRRJNVSR3KLM"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c5QfDd2YSXIS9r"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="f0pn3MKYSXIS9r"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-28166" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/03/13/nicondra-warm-muggy-before-front/"> <img class="width-full " alt="Nicondra: Warm and muggy before front" src="http://www.fox8live.com/resizer/QT9pipuJ0ydIdCygMBs-vhWsTFs=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/GHVHJTVQLZHAPBRVSVGK2AXJNU.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/03/13/nicondra-warm-muggy-before-front/"> Nicondra: Warm and muggy before front</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Nicondra Norwood</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 51m at 4:05 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/03/13/faa-faces-criticism-boeing-jet-ethiopia-crash-grounded-much-world/"> <img class="width-full " alt="Trump issues emergency order grounding Boeing 737 Max 8 and Max 9 planes" src="http://www.fox8live.com/resizer/yXj8mFyQs2M77HUTpDpXqrVVx3w=/178x0:634x342/456x342/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/XTOAUOCBRBEJNFDB3CUNOGO3QY.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/03/13/faa-faces-criticism-boeing-jet-ethiopia-crash-grounded-much-world/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Trump issues emergency order grounding Boeing 737 Max 8 and Max 9 planes</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 2h at 2:53 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/03/13/fbi-says-kidnapping-suspect-could-be-louisiana/"> <img class="width-full " alt="Kidnapping suspect believed to be in La. or Tex. taken into custody." src="http://www.fox8live.com/resizer/pdoVuNgfok03Il5pSwvqAimOGNo=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/FJR3U4YYFZEHVGVFXQV5WNA6SQ.PNG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/03/13/fbi-says-kidnapping-suspect-could-be-louisiana/"> Kidnapping suspect believed to be in La. or Tex. taken into custody.</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Chris Finch</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 2h at 2:49 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2019/03/13/rondreiz-phillips-still-missing-special-segment-air-id-channel/"> <img class="width-full " alt="Rondreiz Phillips still missing, special segment to air on I.D. channel " src="http://www.fox8live.com/resizer/E6sbnSlsvFPkX_hu4RjaLfFjtI8=/1200x900/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/J5I6DTADUVCPVFLS6GSS4CQKV4.png"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2019/03/13/rondreiz-phillips-still-missing-special-segment-air-id-channel/"> Rondreiz Phillips still missing, special segment to air on I.D. channel </a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Jennifer Duckworth</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 2h at 2:32 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fDwoOc2YSXIS9r"> <div id="ad1576-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1576" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1576",slotName:"wvue/web/news/crime",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"IW7GYJUZENG55LFRRJNVSR3KLM"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="f0mq95IYSXIS9r"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="http://www.fox8live.com"> <div class="logo logo-slim"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 1025 S. Jefferson Davis Pkwy.<br/>New Orleans, LA 70125<br/>(504) 486-6161 </p> <a class="call-to-action uppercase color-white" href="http://www.fox8live.com/about-us">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wvue-dt" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@fox8live.com" class="color-white">publicfile@fox8live.com - (504) 486-6161</a></li> <li><a href="http://webpubcontent.raycommedia.com/wvue/pdf/eeo-2017.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.fox8live.com/story/28159737/questions-or-complaints-about-closed-captioning" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">FOX 8 Careers</a></li> <li><a href="www.fox8live.com/2018/09/14/wvue-internship-information/" class="color-white">FOX 8 Internships</a></li> <li><a href="http://www.fox8live.com/2018/08/21/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.fox8live.com/2018/08/21/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/fox8nola" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/FOX8NOLA/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wvue-dt" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@fox8live.com" class="color-white">publicfile@fox8live.com - (504) 486-6161</a></li> <li><a href="http://webpubcontent.raycommedia.com/wvue/pdf/eeo-2017.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.fox8live.com/story/28159737/questions-or-complaints-about-closed-captioning" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">FOX 8 Careers</a></li> <li><a href="www.fox8live.com/2018/09/14/wvue-internship-information/" class="color-white">FOX 8 Internships</a></li> <li><a href="http://www.fox8live.com/2018/08/21/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="http://www.fox8live.com/2018/08/21/terms-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/fox8nola" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/FOX8NOLA/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/r0YveJg3p6KS9r/render.js?v=51'></script> <script async src="/pb/resources/dist/792648f9b5901ea0287e/rm/rm-index792648f9b5901ea0287e.js"></script>